Citrix XenDesktop Session friert ein

XenDesktop 5 Sessions frieren ein

Heute hatten wir mal wieder ein ganz mysteriöses Problem mit unserem Citrix XenDesktop 5 Server. Bei den externen Clients, die sich bei uns in der Firma mit Ihren Desktop´s verbinden kam es immer wieder dazu, dass sich die ICA-Sitzungen nach einigen Minuten komplett eingefroren haben.

Das hat sich so geäußert, dass der virtuelle Desktop zwar für den Anwender noch sichtbar war, aber es ließ sich nicht mehr damit arbeiten bzw. anklicken. Es konnten keine Programme geschlossen werden, aber die Session war immer noch aktiv und sichtbar.

Erst wenn der Anwender das Citrix Fenster geschlossen hat und sich neu verbunden hat, so konnte er an der gleichen Stelle weiterarbeiten. Da passierte allerdings immer nach unterschiedlichen Zeitabständen, mal nach 4 Minuten, nach 10 Minuten, nach 20 Minuten usw.

Es war einfach keine Regelmäßigkeit zu erkennen. Es wurden auch nicht alle Sitzungen gleichzeitig eingefroren sondern immer abwechselnd. Ein Arbeiten war so fast nicht möglich.

Aber warum? Wir hatten am Citrix XenDesktop 5 Server nichts verändert! Weder Windows Updates noch irgendwelche Citrix Hotfixe eingespielt. Daran konnte es nicht liegen!

Dann hatten wir die Internetleitungen im Verdacht, dass diese evtl. kurz wegbrechen. Auch nicht. Dann haben wir die Netzwerkswitche untersucht, ebenfalls nicht. Auch das Neustarten des XenDesktop Servers brachte nichts, auch nicht des vorgeschalteten Citrix Access Gateways. Dort haben wir die Logfiles untersucht, aber auch hier war nichts zu finden.

Als letztes hatten wir dann versucht, die durchgeführte Änderung der Netzwerkmasken im Netzwerk wieder rückgängig zu machen, die wir vor einigen Tagen durchgeführt hatten. Aber warum sollte dies eigentlich den gewünschten Erfolg bringen, wenn es letzte Woche noch einwandfrei lief und die Änderung aber schon länger zurückliegt.

Also haben wir die Netzwerkmaske an die Clients angepaßt und siehe da, das war die Lösung. Warum auch immer muss die Netzwerkmaske des Citrix Access Gateways mit den XenDesktop Clients übereinstimmen, auch wenn die Verbindung mit verschiedenen Netzwerkmasken einwandfrei hergestellt werden konnte.

Ok, Hauptsache es läuft wieder! Solltet Ihr mal das gleiche Problem haben so schaut bitte Eure Netzwerkmasken durch – vielleicht habt Ihr ja das gleiche Problem!

                           

Über den Author Alle Beiträge anzeigen Author Website

Michael

5 KommentareHinterlasse einen Kommentar

Hinterlasse eine Antwort

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind markiert *